English
The Internet threat alert status is currently normal. At present, no major epidemics or other serious incidents have been recorded by Kaspersky Lab’s monitoring service. Internet threat level: 1

libpng "png_decompress_chunk()" Integer Overflow Vulnerability


Secunia ID

SA48026

CVE-ID

CVE-2011-3026

Release Date

16 Feb 2012

Last Change

24 Feb 2012

Criticality

Moderately Critical

Solution Status

Vendor Patch

Software

libpng 1.x

Where

From remote

Impact
System access

This covers vulnerabilities where malicious people are able to gain system access and execute arbitrary code with the privileges of a local user.

Description

A vulnerability has been reported in libpng, which can be exploited by malicious people to potentially compromise an application using the library.

The vulnerability is caused due to an integer overflow error within the "png_decompress_chunk()" function (pngrutil.c) when uncompressing certain chunks, which can be exploited to cause a heap-based buffer overflow.

Successful exploitation may allow execution of arbitrary code but requires tricking the user into opening a specially crafted PNG file.

The vulnerability is reported in versions prior to 1.0.57, 1.2.47, 1.4.9, and 1.5.9.

Solution

Update to version 1.0.57, 1.2.47, 1.4.9, or 1.5.9.

Reported by

Originally reported by Juri Aedla in Google Chrome.

Original Advisory

http://www.libpng.org/pub/png/src/libpng-1.5.9-README.txt